blob: adecf0777d2b1b0de479b6cda92b475e3a8387b9 [file] [log] [blame]
Roger Meier08dc7e82010-12-14 21:38:00 +00001#!/usr/bin/make -f
2# -*- makefile -*-
3# Sample debian/rules that uses debhelper.
4#
5# This file was originally written by Joey Hess and Craig Small.
6# As a special exception, when this file is copied by dh-make into a
7# dh-make output file, you may use that output file without restriction.
8# This special exception was added by Craig Small in version 0.37 of dh-make.
9#
10# Modified to make a template file for a multi-binary package with separated
11# build-arch and build-indep targets by Bill Allombert 2001
12
13# Uncomment this to turn on verbose mode.
14#export DH_VERBOSE=1
15
16# This has to be exported to make some magic below work.
17export DH_OPTIONS
18
19PYVERS := $(shell pyversions -r)
20
Roger Meier681e6042016-01-10 16:25:57 +010021export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
22export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
23export CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
24export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
25
Roger Meier08dc7e82010-12-14 21:38:00 +000026configure: configure-stamp
27configure-stamp:
28 dh_testdir
Roger Meier681e6042016-01-10 16:25:57 +010029
Roger Meier08dc7e82010-12-14 21:38:00 +000030 # Add here commands to configure the package.
31 if [ -f bootstrap.sh ]; then $(CURDIR)/bootstrap.sh; fi
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +090032 $(CURDIR)/configure --prefix=/usr
Roger Meier08dc7e82010-12-14 21:38:00 +000033
34 touch configure-stamp
35
36
37#Architecture
38build: build-arch build-indep
39 # Tests disabled
40 # $(MAKE) -C test check
41
42build-arch: build-arch-stamp
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +090043$(CURDIR)/compiler/cpp/thrift build-arch-stamp: configure-stamp
Roger Meier08dc7e82010-12-14 21:38:00 +000044
Roger Meier08dc7e82010-12-14 21:38:00 +000045 # Compile C++ library
46 $(MAKE) -C $(CURDIR)/lib/cpp
47
Nobuaki Sukegawa11da87e2016-09-10 14:02:19 +090048 # Compile compiler
49 $(MAKE) -C $(CURDIR)/compiler/cpp
50
Roger Meierf3a51e62011-04-12 20:36:12 +000051 # Compile C (glib) library
52 $(MAKE) -C $(CURDIR)/lib/c_glib
53
Roger Meier08dc7e82010-12-14 21:38:00 +000054 # Python library
55 cd $(CURDIR)/lib/py && \
56 for py in $(PYVERS); do \
57 $$py setup.py build; \
58 $$py-dbg setup.py build; \
59 done
60
Roger Meier08dc7e82010-12-14 21:38:00 +000061 # PHP
62 cd $(CURDIR)/lib/php/src/ext/thrift_protocol && \
63 phpize && \
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +090064 ./configure && $(MAKE)
Roger Meier08dc7e82010-12-14 21:38:00 +000065
66 touch $@
67
68build-indep: build-indep-stamp
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +090069build-indep-stamp: configure-stamp $(CURDIR)/compiler/cpp/thrift
Roger Meier08dc7e82010-12-14 21:38:00 +000070
71 # Add here commands to compile the indep part of the package.
72 #$(MAKE) doc
73
74 # Java
75 cd $(CURDIR)/lib/java && \
76 ant
77
Roger Meier08dc7e82010-12-14 21:38:00 +000078 # C#
79 $(MAKE) -C $(CURDIR)/lib/csharp
80
Roger Meier38b7d072011-12-09 10:36:05 +000081 # Ruby
82 $(MAKE) -C $(CURDIR)/lib/rb
83
Roger Meier08dc7e82010-12-14 21:38:00 +000084 # Perl
85 $(MAKE) -C $(CURDIR)/lib/perl INSTALLDIRS=vendor
86
87 touch $@
88
89clean:
90 dh_testdir
91 dh_testroot
92 rm -f build-arch-stamp build-indep-stamp configure-stamp
93
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +090094 cd $(CURDIR)/lib/py && python setup.py clean --all
95
Roger Meier08dc7e82010-12-14 21:38:00 +000096 # Add here commands to clean up after the build process.
97 -$(MAKE) clean
98
jfarrell0c273522016-12-19 14:57:54 -050099 $(CURDIR)/cleanup.sh
100
Roger Meier08dc7e82010-12-14 21:38:00 +0000101 dh_clean
102
103install: install-indep install-arch
104install-indep:
105 dh_testdir
106 dh_testroot
jfarrell0c273522016-12-19 14:57:54 -0500107 dh_prep -i
Roger Meier08dc7e82010-12-14 21:38:00 +0000108 dh_installdirs -i
109
110 # Add here commands to install the indep part of the package into
111 # debian/<package>-doc.
112 #INSTALLDOC#
113
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900114 # Java
Roger Meier08dc7e82010-12-14 21:38:00 +0000115 mkdir -p $(CURDIR)/debian/libthrift-java/usr/share/java/ && \
Roger Meierf3a51e62011-04-12 20:36:12 +0000116 cp $(CURDIR)/lib/java/build/libthrift*.jar \
Roger Meier08dc7e82010-12-14 21:38:00 +0000117 $(CURDIR)/debian/libthrift-java/usr/share/java/
118
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900119 # Ruby
Roger Meier38b7d072011-12-09 10:36:05 +0000120 mkdir -p $(CURDIR)/debian/ruby-thrift/usr/lib/ruby/1.9.1 && \
121 cp $(CURDIR)/lib/rb/lib/thrift.rb \
122 $(CURDIR)/debian/ruby-thrift/usr/lib/ruby/1.9.1
123 cp -r $(CURDIR)/lib/rb/lib/thrift \
124 $(CURDIR)/debian/ruby-thrift/usr/lib/ruby/1.9.1
125
Roger Meier08dc7e82010-12-14 21:38:00 +0000126 # C#
127 mkdir -p $(CURDIR)/debian/libthrift-cil/usr/lib/cli/thrift/ && \
128 cp $(CURDIR)/lib/csharp/Thrift.dll \
129 $(CURDIR)/debian/libthrift-cil/usr/lib/cli/thrift/Thrift.dll
130
131 # Perl
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900132 $(MAKE) -C $(CURDIR)/lib/perl install DESTDIR=$(CURDIR)/debian/libthrift-perl
133 mv $(CURDIR)/debian/libthrift-perl/usr/local/lib/perl5 $(CURDIR)/debian/libthrift-perl/usr/lib
134 rmdir $(CURDIR)/debian/libthrift-perl/usr/local/lib
135 rmdir $(CURDIR)/debian/libthrift-perl/usr/local
Roger Meier08dc7e82010-12-14 21:38:00 +0000136
137 dh_install -i
138
139install-arch:
140 dh_testdir
141 dh_testroot
142 dh_clean -k -s
143 dh_installdirs -s
144
145 # Add here commands to install the arch part of the package into
146 # debian/tmp.
147 #$(MAKE) DESTDIR=$(CURDIR)/debian/thrift install
148
Jake Farrellc965dda2011-11-06 20:29:26 +0000149 # Compiler
Roger Meier08dc7e82010-12-14 21:38:00 +0000150 mkdir -p $(CURDIR)/debian/thrift-compiler/usr/bin && \
151 cp $(CURDIR)/compiler/cpp/thrift \
152 $(CURDIR)/debian/thrift-compiler/usr/bin/thrift && \
153 rmdir $(CURDIR)/debian/thrift-compiler/usr/sbin
154
Jake Farrellc965dda2011-11-06 20:29:26 +0000155 # Python
Roger Meier08dc7e82010-12-14 21:38:00 +0000156 cd $(CURDIR)/lib/py && \
Nobuaki Sukegawaf43d0ca2016-03-25 09:22:16 +0900157 python2 setup.py install --install-layout=deb --no-compile --root=$(CURDIR)/debian/python-thrift && \
158 python2-dbg setup.py install --install-layout=deb --no-compile --root=$(CURDIR)/debian/python-thrift-dbg && \
159 python3 setup.py install --install-layout=deb --no-compile --root=$(CURDIR)/debian/python3-thrift && \
160 python3-dbg setup.py install --install-layout=deb --no-compile --root=$(CURDIR)/debian/python3-thrift-dbg
Roger Meier08dc7e82010-12-14 21:38:00 +0000161
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900162 find $(CURDIR)/debian/python-thrift -name "*.py[co]" -print0 | xargs -0 rm -f
163 find $(CURDIR)/debian/python-thrift -name "__pycache__" -print0 | xargs -0 rm -fr
164 find $(CURDIR)/debian/python-thrift-dbg -name "__pycache__" -print0 | xargs -0 rm -fr
165 find $(CURDIR)/debian/python-thrift-dbg -name "*.py[co]" -print0 | xargs -0 rm -f
Roger Meier08dc7e82010-12-14 21:38:00 +0000166 find $(CURDIR)/debian/python-thrift-dbg -name "*.py" -print0 | xargs -0 rm -f
Roger Meier38b7d072011-12-09 10:36:05 +0000167 find $(CURDIR)/debian/python-thrift-dbg -name "*.egg-info" -print0 | xargs -0 rm -rf
Roger Meier08dc7e82010-12-14 21:38:00 +0000168 find $(CURDIR)/debian/python-thrift-dbg -depth -type d -empty -exec rmdir {} \;
169
Nobuaki Sukegawaf43d0ca2016-03-25 09:22:16 +0900170 find $(CURDIR)/debian/python3-thrift -name "*.py[co]" -print0 | xargs -0 rm -f
171 find $(CURDIR)/debian/python3-thrift -name "__pycache__" -print0 | xargs -0 rm -fr
172 find $(CURDIR)/debian/python3-thrift-dbg -name "__pycache__" -print0 | xargs -0 rm -fr
173 find $(CURDIR)/debian/python3-thrift-dbg -name "*.py[co]" -print0 | xargs -0 rm -f
174 find $(CURDIR)/debian/python3-thrift-dbg -name "*.py" -print0 | xargs -0 rm -f
175 find $(CURDIR)/debian/python3-thrift-dbg -name "*.egg-info" -print0 | xargs -0 rm -rf
176 find $(CURDIR)/debian/python3-thrift-dbg -depth -type d -empty -exec rmdir {} \;
177
Roger Meier08dc7e82010-12-14 21:38:00 +0000178 # PHP
179 mkdir -p $(CURDIR)/debian/php5-thrift
180 cd $(CURDIR)/lib/php && \
181 $(MAKE) DESTDIR=$(CURDIR)/debian/php5-thrift install
182
Roger Meierf3a51e62011-04-12 20:36:12 +0000183 # C++ and C (glib)
Roger Meier08dc7e82010-12-14 21:38:00 +0000184 mkdir -p $(CURDIR)/debian/tmp; \
185 cd $(CURDIR)/lib/cpp && \
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900186 $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
Roger Meierf3a51e62011-04-12 20:36:12 +0000187 cd $(CURDIR)/lib/c_glib && \
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900188 $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
Roger Meier08dc7e82010-12-14 21:38:00 +0000189
190 dh_install --sourcedir=debian/tmp -s
191
192
193# Must not depend on anything. This is to be called by
194# binary-arch/binary-indep
195# in another 'make' thread.
196binary-common:
197 dh_testdir
198 dh_testroot
199 dh_installchangelogs
200 dh_installdocs
201 dh_installexamples
202 dh_installman
203 dh_link
Akiraf4577802016-04-16 02:09:49 +0900204 dh_strip -ppython-thrift --dbg-package=python-thrift-dbg
205 dh_strip -ppython3-thrift --dbg-package=python3-thrift-dbg
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900206 dh_strip -pthrift-compiler -plibthrift0
Roger Meier08dc7e82010-12-14 21:38:00 +0000207 dh_compress
208 dh_fixperms
Roger Meier08dc7e82010-12-14 21:38:00 +0000209 dh_makeshlibs
210 dh_installdeb
211 dh_perl
212 dh_shlibdeps
213 dh_gencontrol
214 dh_md5sums
215 dh_builddeb
Konrad Grochowski3b5dacb2014-11-24 10:55:31 +0100216# Build architecture independent packages using the common target.
Roger Meier08dc7e82010-12-14 21:38:00 +0000217binary-indep: build-indep install-indep
218 $(MAKE) -f debian/rules DH_OPTIONS=-i binary-common
219
Konrad Grochowski3b5dacb2014-11-24 10:55:31 +0100220# Build architecture dependent packages using the common target.
Roger Meier08dc7e82010-12-14 21:38:00 +0000221binary-arch: build-arch install-arch
Nobuaki Sukegawa93bbdc82016-03-25 08:51:09 +0900222 echo "php:Depends=phpapi-$(shell php-config5 --phpapi)" > $(CURDIR)/debian/substvars
Roger Meier08dc7e82010-12-14 21:38:00 +0000223 $(MAKE) -f debian/rules DH_OPTIONS=-s binary-common
224
225binary: binary-arch binary-indep
226.PHONY: build clean binary-indep binary-arch binary install install-indep install-arch configure