THRIFT-3460 Improve provided Debian packaging solution

Patch: Filip Chabik & Roger Meier

This closes #721
diff --git a/debian/rules b/debian/rules
index c94de2e..2441a4c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,9 +18,15 @@
 
 PYVERS := $(shell pyversions -r)
 
+export CPPFLAGS:=$(shell dpkg-buildflags --get CPPFLAGS)
+export CFLAGS:=$(shell dpkg-buildflags --get CFLAGS)
+export CXXFLAGS:=$(shell dpkg-buildflags --get CXXFLAGS)
+export LDFLAGS:=$(shell dpkg-buildflags --get LDFLAGS)
+
 configure: configure-stamp
 configure-stamp:
 	dh_testdir
+
 	# Add here commands to configure the package.
 	if [ -f bootstrap.sh ]; then $(CURDIR)/bootstrap.sh; fi
 	$(CURDIR)/configure --prefix=/usr --with-c_glib --without-erlang