THRIFT-2835 Add possibility to distribute generators separately from thrift core, and load them dynamically
Client: Compiler
Patch: Nobuaki Sukegawa, rebased by dtmuller
Also fixed by dtmuller:
* Add plugin namespace for erlang language binding
* Fix unit test test_const_value
* Don't clear type cache with every t_program conversion
* Type "wb" may not be supported by popen on non-Windows platforms
* Fix constness of AST type signatures
diff --git a/debian/rules b/debian/rules
index a31881d..84cba1f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -42,12 +42,12 @@
build-arch: build-arch-stamp
$(CURDIR)/compiler/cpp/thrift build-arch-stamp: configure-stamp
- # Compile compiler
- $(MAKE) -C $(CURDIR)/compiler/cpp
-
# Compile C++ library
$(MAKE) -C $(CURDIR)/lib/cpp
+ # Compile compiler
+ $(MAKE) -C $(CURDIR)/compiler/cpp
+
# Compile C (glib) library
$(MAKE) -C $(CURDIR)/lib/c_glib