THRIFT-4033 disable thrift compiler plug-in support by default, as the thrift-compiler packaging is not ready for it yet

This closes #1157
diff --git a/debian/rules b/debian/rules
index adecf07..46a7f92 100755
--- a/debian/rules
+++ b/debian/rules
@@ -29,7 +29,7 @@
 
 	# Add here commands to configure the package.
 	if [ -f bootstrap.sh ]; then $(CURDIR)/bootstrap.sh; fi
-	$(CURDIR)/configure --prefix=/usr
+	$(CURDIR)/configure --prefix=/usr --enable-plugin=no
 
 	touch configure-stamp
 
@@ -42,12 +42,12 @@
 build-arch: build-arch-stamp
 $(CURDIR)/compiler/cpp/thrift build-arch-stamp: configure-stamp
 
-	# Compile C++ library
-	$(MAKE) -C $(CURDIR)/lib/cpp
-
 	# Compile compiler
 	$(MAKE) -C $(CURDIR)/compiler/cpp
 
+	# Compile C++ library
+	$(MAKE) -C $(CURDIR)/lib/cpp
+
 	# Compile C (glib) library
 	$(MAKE) -C $(CURDIR)/lib/c_glib