THRIFT-4982 Remove deprecated C# bindings from the code base
Client: csharp
Patch: Jens Geyer
This closes #2027
diff --git a/debian/rules b/debian/rules
index e209ba3..d0de508 100755
--- a/debian/rules
+++ b/debian/rules
@@ -76,7 +76,7 @@
./gradlew --no-daemon -Prelease=true jar
# C#
- $(MAKE) -C $(CURDIR)/lib/csharp
+ $(MAKE) -C $(CURDIR)/lib/netstd
# Ruby
$(MAKE) -C $(CURDIR)/lib/rb
@@ -122,9 +122,9 @@
$(CURDIR)/debian/ruby-thrift/usr/lib/ruby/1.9.1
# C#
- mkdir -p $(CURDIR)/debian/libthrift-cil/usr/lib/cli/thrift/ && \
- cp $(CURDIR)/lib/csharp/Thrift.dll \
- $(CURDIR)/debian/libthrift-cil/usr/lib/cli/thrift/Thrift.dll
+ mkdir -p $(CURDIR)/debian/libthrift-netstd/usr/lib/cli/thrift/ && \
+ cp $(CURDIR)/lib/netstd/Thrift/bin/Release/netstandard2.0/Thrift.dll \
+ $(CURDIR)/debian/libthrift-netstd/usr/lib/cli/thrift/Thrift.dll
# Perl
$(MAKE) -C $(CURDIR)/lib/perl install DESTDIR=$(CURDIR)/debian/libthrift-perl